The JAVA SDK is deprecated

  • The OANDA v1 REST API will cease to function for your account as early as May 2018.
  • Please migrate your applications to use the v20 REST API. A Java wrapper is available in the sample code section.

Getting Started


How to get started?

The Java SDK is deprecated and OANDA is no longer accepting new user applications for it. Please use the OANDA v20 REST API instead.